DNS Server
Incident Report for Networks Status
Resolved
This incident has been resolved.
Posted Mar 19, 2022 - 11:07 PDT
Update
Everything should be stable again
Posted Mar 19, 2022 - 11:06 PDT
Update
We are continually working on a permanent fix, our website and customerpanel could be still slow but accessible, our email addresses are also working again!
Posted Mar 18, 2022 - 23:10 PDT
Identified
We are currently experiencing an issue with one of our main DNS servers, this may affect some domains and our customerpanel.ca, the issue has been identified and we are actively working on the situation.
Posted Mar 18, 2022 - 17:53 PDT
This incident affected: CustomerPanel.