We are pleased to inform you that the emergency maintenance on the main low-voltage distribution panel (MDB-C) has been successfully completed, and all power supplies are now fully restored.
Posted Oct 02, 2025 - 11:11 PDT
Update
We are pleased to inform you that the emergency maintenance on the main low-voltage distribution panel (MDB-C) has been successfully completed, and all power supplies are now fully restored.
Posted Oct 02, 2025 - 11:10 PDT
Identified
Our engineer had to temporarily switch off the primary or redundant power supply(s) to multiple cabinets. During this period, the remaining power feeds to the affected cabinets will remain operational, supported by UPS and generator backup. Once the maintenance is completed, the power supply will be fully restored.
Posted Oct 02, 2025 - 08:35 PDT
Investigating
📢 Important Service Update – NL Datacenter (Amsterdam)
We are currently investigating a facilities issue impacting a specific power distribution row in our Netherlands (Amsterdam) datacenter. This is affecting a subset of dedicated server customers, with some machines showing Power Status: Unreachable via the API.
Our NOC is working together with on-site datacenter engineers to restore service as quickly as possible.
Current Impact Incident Identified: A fault in a facilities power distribution row.
Affected Services: A subset of dedicated servers in Amsterdam. Affected hosts are currently unreachable.
Network Status: The wider network infrastructure remains healthy and operational.
Our engineers are on-site and performing diagnostics with the datacenter team.
Data Integrity Once power is restored, all systems will be brought back online in a controlled and sequenced manner to ensure stability and data integrity.
Next Update We are awaiting a facilities update for a confirmed ETA. We will provide the next status update by Oct 3, 2025 · 00:30 +07.
This incident was first reported:
Amsterdam: Oct 2, 2025 · 17:02 CEST
Montreal: Oct 2, 2025 · 11:02 EDT
London: Oct 2, 2025 · 16:02 BST
Bangkok: Oct 2, 2025 · 22:02 +07
PDT: Oct 2, 2025 · 08:02 PDT
Our team is fully engaged, and we appreciate your patience. We will update this page as soon as we have more information.