Amsterdam Datacenter Network Connectivity Issue

Incident Report for Networks Status

Postmortem

📋 Incident Summary

A power outage occurred at our core Amsterdam location. All systems were connected redundantly, but due to force majeure the redundant connection became overloaded, causing the distribution cabinet to trip.

⚠️ Impact
  • Some VPS and dedicated servers in Amsterdam were unreachable
  • Network connectivity interruptions for affected nodes
  • AMS management dashboard access limitations
✅ Actions Taken
  • Issue identified and investigated with datacenter network team
  • Corrective measures implemented
  • Full connectivity restored to all affected nodes
  • Services verified and monitoring confirmed stable
🔧 Preventive Measures
  • Distribution cabinet will be fully replaced as soon as possible
  • Additional C and D power feeds will be added to routing equipment
  • Power infrastructure redundancy will be further improved to prevent recurrence
  • Working closely with datacenter facility to permanently resolve the issue

We sincerely apologize for the inconvenience this incident may have caused and appreciate your patience while we resolved the situation.

Posted Mar 11, 2026 - 12:25 PDT

Resolved

Resolved: March 11, 2026 - 19:19 Amsterdam Time

The network connectivity issue affecting part of our Amsterdam infrastructure has now been fully resolved.

Summary
Earlier today a network interruption within the Amsterdam datacenter caused multiple servers and services to become temporarily unreachable. This also affected connectivity to the AMS management dashboard.

Our engineers worked with the datacenter network team to restore connectivity. Network services have now been fully restored and all affected systems are operating normally.

Incident Timeline
Start: March 11, 2026 – 17:42 Amsterdam Time
Resolved: March 11, 2026 – 19:19 Amsterdam Time
Duration: 1 hour 36 minutes

Impact
• Some Amsterdam VPS and dedicated servers temporarily unreachable
• Network connectivity interruption
• AMS infrastructure dashboard unavailable during the incident

Current Status
All services are operational and connectivity has been restored.

We will continue monitoring the infrastructure to ensure stability.
Posted Mar 11, 2026 - 11:23 PDT

Investigating

Incident Start: March 11, 2026 - 17:42 Amsterdam Time

We are currently investigating a network connectivity issue affecting part of our Amsterdam (NL) infrastructure.

Some servers and services located in the Amsterdam datacenter may currently be unreachable. This also affects the AMS management dashboard.

Our engineers are actively investigating the issue with the datacenter network team.

Impact

Some VPS and dedicated servers located in Amsterdam

Network connectivity to affected nodes

AMS infrastructure dashboard


We will provide updates as soon as additional information becomes available.
Posted Mar 11, 2026 - 11:02 PDT
This incident affected: Netherlands.